пятница, 27 апреля 2012 г.

Cisco - Проброс двух одинаковых портов снаружи внутрь на одном интерфейсе / NAT port tralation of 2 identical ports on 1 WAN interface


Задача:

Имеется 2 Web приложения в корпоративной сети. Оба работают по 80-му порту и другой не приемлют.
Необходимо, чтобы снаружи можно было работать с ними точно также как и из локальной сети, и тоже по 80-му порту, никакой другой нельзя!

Собственно, как настроить маршрутизатор Cisco с одним интерфейсом, подключённым к Интернет, так, чтобы он мог пробрасывать 2 одинаковых порта (в данном случае 80), на те веб-приложения, что указаны выше.

*В наличии имеется сеть из 6 глобальных IP адресов ( в общем располагаем IP из Интернет).

Решение:

>>было:
interface fa0/1
ip address 95.66.66.58 255.255.255.248

ip route 0.0.0.0 0.0.0.0 95.66.66.57


ip nat inside source static tcp 192.168.0.21 80 interface FastEthernet0/1 80


>>стало:

interface fa0/1
ip address 95.66.66.58 255.255.255.248
ip address 95.66.66.59 255.255.255.248 seccondary
*присваиваем второй IP интерфейсу и указывает, что он вторичный

ip route 0.0.0.0 0.0.0.0 95.66.66.57


ip nat inside source static tcp 192.168.0.21 80  95.66.66.58  80 extendable
ip nat inside source static tcp 192.168.0.20 80  95.66.66.59 80 extendable


*тут важно указывать не interface FastEthernet0/1, а внешний IP!!!

Комментариев нет:

Отправить комментарий