понедельник, 14 мая 2012 г.

Настройка Cisco - провайдер NetByNet



Настройка роутера Cisco для подключения по PPPOE к NetByNet

hostname c2811
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
logging buffered 51200 warnings
!
aaa new-model
!
!
aaa authentication login default local
!
!
aaa session-id common
memory-size iomem 15
!
dot11 syslog
ip source-route
!
ip cef
!
ip domain name domain.local
ip name-server 212.1.224.34
ip name-server 212.1.230.111
no ipv6 cef
!
multilink bundle-name authenticated
!
!
username root privilege 15 secret 5 $315$aI54yK
archive
 log config
  hidekeys
!
!
ip ssh version 2
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
 pppoe enable group global
 pppoe-client dial-pool-number 1
!
interface FastEthernet0/1
 ip address 192.168.13.51 255.255.255.0
 ip mtu 1452
 ip nat inside
 no ip virtual-reassembly
 ip tcp adjust-mss 1380
 duplex auto
 speed auto
!interface wlan-controller1/0
 no ip address
 shutdown
!
interface Dialer0
 ip address negotiated
 ip mtu 1492
 ip nat outside
 ip virtual-reassembly
 encapsulation ppp
 dialer pool 1
 dialer-group 1
 no cdp enable
 ppp authentication chap callin
 ppp chap hostname 65767992
 ppp chap password 7 02041454095F091C
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 Dialer0
no ip http server
no ip http secure-server
!
!
ip dns server
ip nat inside source list wan interface Dialer0 overload
!
ip access-list extended wan
 permit ip 192.168.13.0 0.0.0.255 any
!

из-за отсутствия второй строки (что выделена жирным крупным) инет работал странно, все меседжеры - да, web-surfing - нет. Ни одна страница не открывалась.

2 комментария:

  1. будет этот конфиг работать на Cisco 1812j ?

    у вас не прописаны статические маршруты, без них открываются локальные ресурсы НБН, форум например?

    ОтветитьУдалить
  2. Должно работать. Только вы не вздумайте просто копи-пастить. Поэтапам создавайте свой конфиг на базе этого.
    Локальными ресерсами не пользовался. Но маршруты не проблема.
    Если нужна будет помощь, пишите.

    ОтветитьУдалить