суббота, 31 января 2015 г.

Экспорт ящиков в PST Exhcange 2013

Подготовка:
1) Предоставить права пользователю, которым вы будете проводить экспорт:
    New-ManagementRoleAssignment –Role “Mailbox Import Export” –User Ivanov
     либо для группы:
    New-ManagementRoleAssignment -Role "Mailbox Import Export" -SecurityGroup ExchangeAdmGroup
2) Перелогиниться на в RDP сессии сервера, на котором Exchange;

Экспорт всех имеющихся в базе ящиков:
foreach ($mbx in (Get-Mailbox -Database 'MAIN')) { New-MailboxExportRequest -Mailbox $mbx -FilePath "\\Server1\PST\$($mbx.DisplayName) $(get-date -uformat "%Y").$(get-date -uformat "%m").$(get-date -uformat "%d").pst" }

четверг, 29 января 2015 г.

Безопасность Linux - Отключить логин по ROOT и дать права root пользователю USER


1) Меняем права на файл Sudoers:
   chmod 775 sudoers
2) Добавляем пользователя Ivanov в Sudoers:
   $vi /etc/sudoers
      после строки
     root                    ALL=(ALL)       ALL
      вставляем
     Ivanov                    ALL=(ALL)       ALL
3) Возвращаем права на файл обратно:
     chmod 440 sudoers
4) Создаём пользователя:
     adduser -G root Ivanov
     passwd ******
5) Запрещаем авторизацию по ssh под Root:
     vi /etc/ssh/sshd_config
      меняем строку на
     PermitRootLogin no

Zimbra dsn=4.4.1, status=deferred (connect to domain.com[ IP address ]:7025: Connection refused

Проблема:
Почта ходила только наружу. Внутри между ящиками и снаружи тишина. В логах:

Jan 29 18:39:55 mydomain postfix/lmtp[18749]: 6143D73: to=<admin@mydomain.com>, relay=none, delay=0.06, delays=0.03/0.02/0.01/0, dsn=4.4.1, status=deferred (connect to mydomain.com [76.18.198.13]:7025: Connection refused)

Причина:
Когда письмо с адресатом в домене mydomain.com приходило на Zimbra сервер, Zimbra брала имя домена, в данном случае mydomain.com, и резолвила через указанные в /etc/resolv.conf в IP адрес. Так как DNS сервер в локальной сети (он же и домен-контроллер) ничего не знал про зону mydomain.com, то он переправлял запрос в Интернет. А уже в глобальной паутине mydomain.com резолвился в 76.18.198.13. После Zibra обалдевает, так как ожидает IP адрес из локальной сети (фактически IP адрес из локальной сети, который присвоен самой Zimbra).

понедельник, 26 января 2015 г.

Ошибка при загрузке CentOS 6.5 - Kernel Panic - not syncing: Attempted to kill init!


При установке VMware Tools ответил yes на изменение kernel модулей.
Также перед перезагрузкой по ошибке не выключил SElinux.

Решение:
1) Загрузиться с Инсталяционого диска;
2) Выбрать режим восстановления;
3) Ввести IP для сетевой карты на время данной операции;
4) В консоли выполнить:
                   vi /mnt/sysimage/etc/selinux/config;
5) Выставить параметр в SELINUX=disabled.
/mvi /mnt/sysimage/etc/selinux/config nt/sysimage/etc/selinux/config

Установка Zimbra 8.6 на CentOS 6.5 (виртуальная машина ESXi 5.5) / Install Zimbra 8.6 on CentOS 6.5 (hosted by ESXi 5.5)

6.58.6
Развёртывание почтового сервера Zimbra на виртуальную машину с ОС CentOS 6.5.
Данное решение бесплатно и не имеет лицензионных ограничений.
Не рекомендуется на сегодняшний день ставить на CentOS 7.

воскресенье, 25 января 2015 г.

Замена Compact Flash на Cisco маршрутизаторе

1. В программе Tera Term VT подключиться к Cisco через Console

2. rommon 1 > xmodem -r
Соглашаемся и вводим "y"


3. Открываем прошивку для нашей модели. File > Transfer > XMODEM > Send > firmware.bin

Из Cisco LAP в Cisco AP

Переименовать прошивку для автоматического обновления из c1140-k9w7-tar.152-4.JA1.tar в c1140-k9w7-tar.default

1. Подключить Cisco LAP к ПК (10.0.0.2 255.0.0.0)

2. Запустить TFTP сервер (tftp32) с указанием таймаута 30 секунд и директории где лежит указанный IOS

3. Зажать кнопку MODE и подать питание на точку, когда индикатор загорится красным - отпустить

VMware ESXi 5.5 - Network Teaming


Cisco:

interface Port-channel1
switchport
switchport access vlan 100
switchport mode access
no ip address
!
interface GigabitEthernet1/1
switchport
switchport access vlan 100
switchport mode access
no ip address
channel-group 1 mode on
!

VMware ESXi 5.5 Networkin TroubleShooting


To initiate a vmkping test from the console of an ESX Server host:

Connect to the ESX/ESXi host using an SSH session. For information see Tech Support Mode for Emergency Support (1003677) and Using Tech Support Mode in ESXi 4.1 and 5.0 (1017910).

In the command shell, run the command:

# vmkping x.x.x.x

where x.x.x.x is the hostname or IP address of the server that you want to ping.

суббота, 24 января 2015 г.

ESXi 5.5 - Datastore '' conflicts with an existing datastore in the datacenter that has the same URL


Проблема в том, что некоторые виртуальные машины, шаблоны или ещё какие объекты ссылаются на Datastore, которого уже нет, тем самым не давай возможности удалить этот Datastore.

Решение:

четверг, 22 января 2015 г.

Cisco URL Filtering on Router / Блокировка URL


class-map match-any URL-BLOCK-CLASS
 match protocol http host "*youtube*"
 match protocol http host "*vk*"

policy-map URL-BLOCK-POLICY
 class URL-BLOCK-CLASS
   drop

interface FastEthernet0/1
  service-policy input URL-BLOCK-POLICY

среда, 21 января 2015 г.

Очистка кэша Outlook / Clear Outlook Cache


CLS
ECHO OFF

ECHO Reset the nickname and the automatic completion caches in Outlook 2002-2013 on Windows XP, Vista, 7
ECHO .
REM CMD Script

суббота, 17 января 2015 г.

MS SQL - скрипт вывода размеров таблиц базы



SET nocount ON

IF NOT object_id('tempdb..[#space]') IS NULL DROP TABLE [#space]

declare @TABLE [sysname]

CREATE TABLE [#space] (
        [name] [nvarchar](128),
        [rows] [char](11),
        [rows_int] [int],
        [reserved] [varchar](18),
        [DATA] [varchar](18),
        [data_int] [int],
        [index_size] [varchar](18),
        [unused] [varchar](18),
        [unused_int] [int]
)

declare [c] cursor FOR

четверг, 15 января 2015 г.

SQL 2008 Property Owner is not available for Database


Нужно изменить владельца базы:

use TEST
exec sp_changedbowner 'sa'

*Меняем владельца базы TEST на пользователя sa

среда, 14 января 2015 г.

Драйвер для USB-COM переходника (VID - 1A86, DID - 7523) - HL-340


Window ОС автоматически не находит драйвера для данного кабеля.
Его ID устройства 7523, а ID производителя - 1А86.
Сайт www.pcidatabase.com не знает кто это тоже.

Порылся немного ещё. Нашёл решение тут luan78zao.wordpress.com
Название ему HL-340.

Драйвер можно скачать тут - drive.google.com

воскресенье, 4 января 2015 г.

BitTorrentSync как сервис / BitTorrentSynс as service



0) Скачать, установить BitTorrentSync, убрать галку "Запускать при старте системы";
1) Скачать instsrv.exe и srvany.exe и положить в папку куда установлен BitTorrentSync;
2) Запустить командную строку с максимальными правами: runas /user:administrator cmd
     (желательно локальный, но думаю можно и доменного);
3) cd "C:\Program Files\BitTorrent Sync";
4) Установить сам сервис instsrv.exe BTSync.exe "C:\Program Files\BitTorrent Sync\srvany.exe";
5) Запусить regedit (в cmd);
6) Перейти в HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\BTSync.exe
7) Создать Key (ключ), назвать Parameters;
8) В Parameters создать String Value и назвать Application
9) В значении Application прописать C:\Program Files\BitTorrent Sync\BTSync.exe;
10) Зайти в оснастку Services, найти BTSync.exe, в свойствах установить в General запуск - Automatic, Log On - Local System account (Log On может иметь и другое значение);
11) Запустить сервис нажав Start.