вторник, 9 августа 2016 г.

Агрегация сетевых интерфейсов Cisco Switch + Windows Server

Настройка агрегации каналов для повышения пропускной способности и отказоустойчивости.
Cisco Switch и Windows Server

Агрегация на Cisco Switch

switch(config)# interface range Gi0/21-22
switch(config-if-range)# shutdown
switch(config-if-range)# channel-group 1 mode active
      Creating a port-channel interface Port-channel 1
switch(config-if-range)# no shutdown
switch(config-if-range)# exit
switch(config)# interface Port-channel 1switch(config-if)# description LACP channel for Storage
switch(config-if)# switchport trunk encapsulation dot1q
switch(config-if)# switchport trunk allowed vlan 1,2,4
switch(config-if)# switchport mode trunk
switch(config-if)# exit

switch(config)# interface GigabitEthernet0/21
switch(config-if)# description LACP channel for Storage
switch(config-if)# channel-protocol lacp
switch(config-if)# exit

switch(config)# interface GigabitEthernet0/22
switch(config-if)# description LACP channel for Storage
switch(config-if)# channel-protocol lacp
switch(config-if)# exit


switch# show interfaces status
...
Gi0/21  LACP channel for K  connected  trunk  a-full a-1000 10/100/1000BaseTX
Gi0/22  LACP channel for K  connected  trunk  a-full a-1000 10/100/1000BaseTX
...
Po2     LACP channel for K  connected  trunk  a-full a-1000
...

switch# show lacp internal
...
Channel group 2
                            LACP port     Admin     Oper    Port     Port
Port      Flags   State     Priority      Key       Key     Number   State
Gi0/21    SA      bndl      32768         0x2       0x2     0x15     0x3D
Gi0/22    SA      bndl      32768         0x2       0x2     0x16     0x3D
...

Агрегация на Windows Server


1. Если у вас сетевые карты Intel

- Вам нужно только установить дополнительный софт от Intel
Intel® PROSet for Windows
- Зайти в настройки сетевого интерфейса, найти там Дополнительно
- Создать Team

2. Если у вас Windows Server 2012R2 и выше

- Открыть Server Manager
- Перейти в NIC Teaming
- Создать Team




Комментариев нет:

Отправить комментарий