четверг, 6 апреля 2017 г.

Агрегация сетевых интерфейсов Cisco Switch и CentOS7.3

Настройка агрегации каналов для повышения пропускной способности и отказоустойчивости.
Cisco Switch и CentOS7.3

Агрегация на CentOS7.3

Проверка наличия модуля поддержки bonding (команда должна отработать без ошибок):
# modinfo bonding
Провека интерфейсов - могут ли работать с MII
# ethtool enp3s0 | grep "Link detected:"
Закидываем параметр в modprobe
# echo "alias bond0 bonding" > /etc/modprobe.d/bonding.conf
# modprobe bond0
Создаём интерефейс агрегации:
# vi /etc/sysconfig/network-scripts/ifcfg-bond0
IPADDR="192.168.0.30"
PREFIX="24"
GATEWAY="192.168.0.1"
DNS1="192.168.0.2"
DNS2="192.168.0.1"
DEVICE=bond0
NAME=bond0
TYPE=Bond
BONDING_MASTER=yes
IPV6INIT=no
MTU=9000
ONBOOT=yes
USERCTL=no
NM_CONTROLLED=no
BOOTPROTO=none
BONDING_OPTS="mode=802.3ad xmit_hash_policy=layer2+3 lacp_rate=1 miimon=100"

Перегружаем NetworkManager
# service network restart
# ifup bond0
Настраиваем 1-ый сетевой интерфейс как часть агрегированного канала
vi /etc/sysconfig/network-scripts/ifcfg-eth0
DEVICE=eth0
NAME=bond0-slave0
TYPE=Ethernet
MTU=9000
BOOTPROTO=none
ONBOOT=yes
MASTER=bond0
SLAVE=yes
USERCTL=no
NM_CONTROLLED=no

Настраиваем 1-ый сетевой интерфейс как часть агрегированного канала
vi /etc/sysconfig/network-scripts/ifcfg-eth1
DEVICE=eth1
NAME=bond0-slave1
TYPE=Ethernet
MTU=9000
BOOTPROTO=none
ONBOOT=yes
MASTER=bond0
SLAVE=yes
USERCTL=no
NM_CONTROLLED=no

Если используете NetworkManager, то перезагрузите  конфигурацию с учётном созданных/изменённых файлов ifcfg-*:
# nmcli con reload
Перезапуск slave-интерфейсов
# ifdown eth0 && ifup eth0
# ifdown eth1 && ifup eth1
Можно также перегрузить полностью NetworkManager
#service network restart
Смотрим, что получилось:
# ip link show
============================================

Агрегация на Cisco Switch

switch(config)# interface range Gi0/21-22

switch(config-if-range)# shutdown
switch(config-if-range)# channel-group 1 mode active
      Creating a port-channel interface Port-channel 1
switch(config-if-range)# no shutdown
switch(config-if-range)# exit

switch(config)# interface Port-channel 1
switch(config-if)# description LACP channel for Storage
switch(config-if)# switchport trunk encapsulation dot1q

switch(config-if)# switchport mode trunk
switch(config-if)# exit

switch(config)# interface range Gi0/21-22
switch(config-if)# description LACP channel for Storage
switch(config-if)# switchport trunk encapsulation dot1q
switch(config-if)# switchport mode trunk
switch(config-if)# channel-group 1 mode active
switch(config-if)# exit

switch# show interfaces status
...
Gi0/21  LACP channel for K  connected  trunk  a-full a-1000 10/100/1000BaseTX
Gi0/22  LACP channel for K  connected  trunk  a-full a-1000 10/100/1000BaseTX
...
Po2     LACP channel for K  connected  trunk  a-full a-1000
...

switch# show lacp internal
...
Channel group 2
                            LACP port     Admin     Oper    Port     Port
Port      Flags   State     Priority      Key       Key     Number   State
Gi0/21    SA      bndl      32768         0x2       0x2     0x15     0x3D
Gi0/22    SA      bndl      32768         0x2       0x2     0x16     0x3D
...

www.charleshooper.net
www.stankowic-development.net
cisco3750x.weebly.com
blog.it-kb.ru

Комментариев нет:

Отправить комментарий